Aqua Euro .1 HP Max Chill Aquarium Chiller - Up to 80 gal.

3 Reviews
$499.95
SKU: 253982
Manufacturer: Aqua Euro USA
MPN: AC10H

This item is currently out of stock

Add product to cart backorder. A customer service representative will contact you regarding your order

Inventory is real time and can be impacted at any time.

Out of Stock

Details

Simple operation, installation and dollar saving compressors make Max Chill Chillers easy to live with. Digital controls and display provide hassle-free access to temp settings and information. Male insert inlet and outlet connections make installation a breeze. Rubber feet soak up vibrations and make Max Chillers silent. Saltwater-proof titanium heat exchangers and removable air filters provide reliability and durability. Filled with ozone-friendly DuPont refrigerants. Includes fittings.

Uses .5" inlet and .625" outlet fittings. Ideal for tanks up to 80 gallons. Cools an 80 gallon tank by 10?F or a 60 gallon tank by 20 degrees F. 65 - 315 gph recommended flow rate. Provides 1485 BTU of cooling power.

Specifications

Specifications
MPN
601002
Manufacturer
Aqua Euro
Internal Id
46166

Instructions

For complete product information download the instruction manual.

Ratings & Reviews

3 reviews

  • 4 stars
  • 0 reviews
  • 2 stars
  • 0 reviews
  • 1 star
  • 0 reviews

Missing items

by

This unit does NOT come with water pump or tubing. Thhose must be purchased separately.

Excellent!

by

I have used this chiller for 2 years now and have been very pleased with the results. I effectively keeps my 50 gallon mixed reef tank cool. It is not loud which is a plus. I have a lot of corals in it and am glad I bought this unit. The price here is about $60 less than what I paid at my local fish store. Someone on here complained that it didnt come with the pump or tubing but no chiller does. Overall, I am happy with this.

Totally Needed for my tank

by

The 1/10th HP is a bargain and it works really well. It is SO HELPFUL in keeping my temperatures in check. It's easy to use too. Took me about 10 minutes to get it up and running.